改成文华指标-文华财经知识 -程序化交易(CXH99.COM)
您现在的位置:程序化交易>> 期货公式>> 文华财经>> 文华财经知识>>正文内容

改成文华指标 [文华财经]

  • 咨询内容:  老师好,帮我改成文华指标:

    {DMI新编}N:=21;M:=6;M1:=20;TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);HD :=HIGH-REF(HIGH,1);LD :=REF(LOW,1)-LOW;DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),N);DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),N);PDI:= DMP*100/TR1;MDI:= DMM*100/TR1;ADX: EMA((PDI-MDI)/(MDI+PDI)*100,M)*2;ADXR:EMA(ADX,M);ADMA1:EMA(ADX,M1);OMD:(ADX-2*ADMA1+ADXR)/2, COLORSTICK;DRAWBAND(ADX,RGB(155,50,50),ADXR,RGB(0,100,50));STICKLINE(OMD>REF(OMD,1) AND OMD>0,0,OMD,1,0),COLORRED;STICKLINE(OMD>REF(OMD,1) AND OMD<0,0,OMD,1,0),COLORGREEN;STICKLINE(OMD<REF(OMD,1),0,OMD,1,0),COLORCBCBC0;STICKLINE(OMD>=0 OR OMD<=0,0,0,50,1),COLORWHITE;ADX1:ADX,COLORRED;ADXR1:ADXR,COLORGREEN;ADMA1:ADMA1;强:IF(ADX1>=ADXR1,ADX1,DRAWNULL),COLORRED,LINETHICK3;买入:IF(OMD>0 AND OMD-REF(OMD,1)>0,30,0);{OMD;}110;0;-110;

     

     来源:程序化99

  • 文华技术人员:  参考,

    N:=21; M:=6; M1:=20; TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N); HD :=HIGH-REF(HIGH,1); LD :=REF(LOW,1)-LOW; DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),N); DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),N); PDI:= DMP*100/TR1; MDI:= DMM*100/TR1; ADX: EMA((PDI-MDI)/(MDI+PDI)*100,M)*2; ADXR:EMA(ADX,M); ADMA1:EMA(ADX,M1); OMD:(ADX-2*ADMA1+ADXR)/2, COLORSTICK; FILLRGN(C>0,ADX,ADXR,RGB(0,100,50)); STICKLINE(OMD>REF(OMD,1) AND OMD>0,0,OMD,1,0),COLORRED; STICKLINE(OMD>REF(OMD,1) AND OMD<0,0,OMD,1,0),COLORGREEN; STICKLINE(OMD<REF(OMD,1),0,OMD,1,0),COLORCBCBC0; STICKLINE(OMD>=0 OR OMD<=0,0,0,50,1),COLORWHITE; ADX1:ADX,COLORRED; ADXR1:ADXR,COLORGREEN; 强:IF(ADX1>=ADXR1,ADX1,NULL),COLORRED,LINETHICK3; 买入:IF(OMD>0 AND OMD-REF(OMD,1)>0,30,0); 110; 0; -110;

     

     来源: WWW.CXH99.COM

  • 文华客服: 老师好,上面的指标已装了。但与原指标的图还有不同,不同处:原先ADXg与ADXR金叉时所围的面积是红色的,:ADXg与ADXR死叉时所围的面积是绿色的,现在全部是绿色的。能不能和原先的一样?

     

  • 网友回复:   参考,
    N:=21;M:=6;M1:=20;TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);HD :=HIGH-REF(HIGH,1);LD :=REF(LOW,1)-LOW;DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),N);DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),N);PDI:= DMP*100/TR1;MDI:= DMM*100/TR1;ADX: EMA((PDI-MDI)/(MDI+PDI)*100,M)*2;ADXR:EMA(ADX,M);ADMA1:EMA(ADX,M1);OMD:(ADX-2*ADMA1+ADXR)/2, COLORSTICK;FILLRGN(ADX<ADXR,ADX,ADXR,RGB(0,100,50));FILLRGN(ADX>ADXR,ADX,ADXR,COLORRED);STICKLINE(OMD>REF(OMD,1) AND OMD>0,0,OMD,1,0),COLORRED;STICKLINE(OMD>REF(OMD,1) AND OMD<0,0,OMD,1,0),COLORGREEN;STICKLINE(OMD<REF(OMD,1),0,OMD,1,0),COLORCBCBC0;STICKLINE(OMD>=0 OR OMD<=0,0,0,50,1),COLORWHITE;ADX1:ADX,COLORRED;ADXR1:ADXR,COLORGREEN;强:IF(ADX1>=ADXR1,ADX1,NULL),COLORRED,LINETHICK3;买入:IF(OMD>0 AND OMD-REF(OMD,1)>0,30,0);110;0;-110;

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容