通达信改博弈,谢谢老师。-博易大师知识 -程序化交易(CXH99.COM)
您现在的位置:程序化交易>> 期货公式>> 博易大师>> 博易大师知识>>正文内容

通达信改博弈,谢谢老师。 [博易POBO]

咨询内容:

通达信改博弈,谢谢老师。

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV2:=EMA(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
MAC3:=MA(C,3);
DIF: EMA(CLOSE,12)- EMA(CLOSE,26),COLORYELLOW;
DEA  : EMA(DIF,9),COLORFF9900 ;
MACD:=(DIF-DEA)*2;
STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORYELLOW;
吸:=MACD<0 AND MACD>REF(MACD,1);
拉:=MACD>0 AND MACD>REF(MACD,1);
派:=MACD>0 AND MACD<REF(MACD,1);
落:=MACD<0 AND MACD<REF(MACD,1);
STICKLINE(吸,0,MACD,1,0),COLORLIRED;
STICKLINE(拉,0,MACD,1,0),COLORRED;
STICKLINE(派,0,MACD,1,0),COLORGREEN;
STICKLINE(落,0,MACD,1,0),COLORWHITE;
主力买1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;
主力买2:IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLOR00FF00,LINETHICK2;
低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;
STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;
DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
DRAWTEXT(底背离,0.12,'底背离'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;

 

 来源:程序化99网( WWW.CXH99.COM )

博易技术人员: 改为:
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV2:=EMA(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
MAC3:=MA(C,3);
DIF: EMA(CLOSE,12)- EMA(CLOSE,26),COLORYELLOW;
DEA  : EMA(DIF,9),COLORFF9900 ;
MACD:=(DIF-DEA)*2;
STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORYELLOW;
吸:=MACD<0 AND MACD>REF(MACD,1);
拉:=MACD>0 AND MACD>REF(MACD,1);
派:=MACD>0 AND MACD<REF(MACD,1);
落:=MACD<0 AND MACD<REF(MACD,1);
STICKLINE(吸,0,MACD,1,0),COLOR8080FF;
STICKLINE(拉,0,MACD,1,0),COLORRED;
STICKLINE(派,0,MACD,1,0),COLORGREEN;
STICKLINE(落,0,MACD,1,0),COLORWHITE;
PARTLINE(DIF>REF(DIF,1),DIF),COLORRED,LINETHICK2;
PARTLINE(DIF<REF(DIF,1),DIF),COLOR00FF00,LINETHICK2;
低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;
STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;
DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
DRAWTEXT(底背离,0.12,'底背离'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2; 来源 程序化久久网

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容