三阳开泰一元复始公式源码副图指标-通达信公式 -程序化交易(CXH99.COM)
您现在的位置:程序化交易>> 股票公式>> 通达信>> 通达信公式>>正文内容

三阳开泰一元复始公式源码副图指标[通达信公式]

相关标签:通达信无未来指标源码 、 通达信kd指标公式源码 、 通达信主图指标源码 、 通达信kdj副图源码 、 通达信鱼身副图源码 、 通达信无未来指标公式 、 通达信三macd指标公式 、 通达信主图指标公式 、 通达信四量图指标源码 、 通达信最好的副图指标 、 通达信龙虎榜副图指标 、 通达信分时图指标公式 、 通达信分时副图指标 、 通达信副图全仓指标 、 通达信乖离率指标副图 、

 

VAR1:=REF(CLOSE,1);
VAR2:=SMA(MAX(CLOSE-VAR1,0),18,1)/SMA(ABS(CLOSE-VAR1),13,1)*100;
VAR3:=SMA(MAX(CLOSE-VAR1,0),24,1)/SMA(ABS(CLOSE-VAR1),20,1)*100;
VAR4:=BARSLAST(VAR3<48)<=3 AND CROSS(VAR2,VAR3);
VAR5:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,20)*100<-12.5;
VAR6:=LLV(LOW,5);
VAR7:=HHV(HIGH,10);
VAR8:=EMA((CLOSE-VAR6)/(VAR7-VAR6)*100,4);
VAR9:=EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);
低吸:=0-(-1)*VAR4 AND VAR5 AND CROSS(VAR8,VAR9) AND VAR8<=25;
DRAWTEXT(低吸>0,0.9,'低吸');
IF(低吸>0,1,0);
VARC:=REF(CLOSE,1);
VARD:=SMA(MAX(CLOSE-VARC,0),7,1)/SMA(ABS(CLOSE-VARC),7,1)*100;
VARE:=SMA(MAX(CLOSE-VARC,0),13,1)/SMA(ABS(CLOSE-VARC),13,1)*100;
VARF:=BARSLAST(VARE<43)<=3 AND CROSS(VARD,VARE);
VAR10:=(CLOSE-MA(CLOSE,43))/MA(CLOSE,20)*100<-12.5;
VAR11:=LLV(LOW,5);
VAR12:=HHV(HIGH,10);
VAR13:=EMA((CLOSE-VAR11)/(VAR12-VAR11)*100,4);
VAR14:=EMA(0.667*REF(VAR13,1)+0.333*VAR13,2);
一元复始:=0-(-1)*VARF AND VAR10 AND CROSS(VAR13,VAR14) AND VAR13<=25;
DRAWTEXT(一元复始>0,1.7,'一元复始');
IF(一元复始>0,2,0);
VAR17:=REF(CLOSE,1);
VAR18:=SMA(MAX(CLOSE-VAR17,0),7,1)/SMA(ABS(CLOSE-VAR17),7,1)*100;
VAR19:=SMA(MAX(CLOSE-VAR17,0),13,1)/SMA(ABS(CLOSE-VAR17),13,1)*100;
VAR1A:=BARSLAST(VAR19<33)<=3 AND CROSS(VAR18,VAR19);
VAR1B:=(CLOSE-MA(CLOSE,33))/MA(CLOSE,20)*100<-12.5;
VAR1C:=LLV(LOW,5);
VAR1D:=HHV(HIGH,10);
VAR1E:=EMA((CLOSE-VAR1C)/(VAR1D-VAR1C)*100,4);
VAR1F:=EMA(0.667*REF(VAR1E,1)+0.333*VAR1E,2);
二气调和:=0-(-1)*VAR1A AND VAR1B AND CROSS(VAR1E,VAR1F) AND VAR1E<=25;
DRAWTEXT(二气调和>0,2.5,'二气调和');
IF(二气调和>0,3,0);
VAR22:=REF(CLOSE,1);
VAR23:=SMA(MAX(CLOSE-VAR22,0),7,1)/SMA(ABS(CLOSE-VAR22),7,1)*100;
VAR24:=SMA(MAX(CLOSE-VAR22,0),13,1)/SMA(ABS(CLOSE-VAR22),13,1)*100;
VAR25:=BARSLAST(VAR24<23)<=3 AND CROSS(VAR23,VAR24);
VAR26:=(CLOSE-MA(CLOSE,23))/MA(CLOSE,20)*100<-12.5;
VAR27:=LLV(LOW,5);
VAR28:=HHV(HIGH,10);
VAR29:=EMA((CLOSE-VAR27)/(VAR28-VAR27)*100,4);
VAR2A:=EMA(0.667*REF(VAR29,1)+0.333*VAR29,2);
三阳开泰:=0-(-1)*VAR25 AND VAR26 AND CROSS(VAR29,VAR2A) AND VAR29<=25;
DRAWTEXT(三阳开泰>0,3.3,'三阳开泰');
IF(三阳开泰>0,4,0);
DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;


DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

 

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容