您现在的位置:程序化交易>> 股票公式>> 通达信>> 通达信公式>>正文内容

全新组合波段王副图指标、代码源码[通达信公式]

相关标签: 通达波段信副图指标 、 波段之王指标 、 通达信指标之王无未来 、 何雪萍指标源码 、 波段之王买卖主图源码 、 通达信冠军一号波段王 、 波段之王副图指标源码 、 通达信波段源码无未来 、 波段王主图指标公式 、 通达信副图指标波段王 、 通达信波段源码副图 、 通达信暴涨波段王指标 、

 

 

 

原理解析:

M赋值:3
AA赋值:20日前的最高价=2*20+1日内最高价的最高值
QY赋值:若AA则将最近20+1周期置为1
CC赋值:QY的20日过滤 AND 最高价=20+1日内最高价的最高值
DDD赋值:上次CC距今天数
GDTS赋值:如果CC,返回到最后交易的周期,否则返回0
DINGBU赋值:如果DDD,返回DDD日前的最高价,否则返回最高价
DINGBUTS赋值:如果DDD,返回DDD日前的GDTS,否则返回GDTS
DINGBU1赋值:DDD+1日前的DINGBU
GDCS1赋值:DINGBUTS的最后一日取值设为常数
DINGBUTS1赋值:DDD+1日前的DINGBUTS
GDCS2赋值:DINGBUTS1的最后一日取值设为常数
DINGBU2赋值:DDD+1日前的DINGBU1
MM赋值:如果到最后交易的周期>GDCS2,返回0,否则返回1
输出高点压力:当满足条件到最后交易的周期=GDCS2时,在最高价位置画直线起点,当满足条件到最后交易的周期=GDCS1时,在最高价位置画直线终点,1表示是否延长.,画洋红色
当满足条件到最后交易的周期=GDCS2时,在最高价位置画直线起点,当满足条件是否最后一个周期时,在GDCS2-1日前的最高价位置画直线终点,1表示是否延长.,COLOR00FF00,POINTDOT,线宽为2
当满足条件到最后交易的周期=GDCS1时,在最高价位置画直线起点,当满足条件是否最后一个周期时,在GDCS1-1日前的最高价位置画直线终点,1表示是否延长.,COLOR00FF00,POINTDOT,线宽为2
AA1赋值:20日前的最低价=2*20+1日内最低价的最低值
QY1赋值:若AA1则将最近20+1周期置为1
CC1赋值:QY1的20日过滤 AND 最低价=20+1日内最低价的最低值
DD1赋值:上次CC1距今天数
DDTS赋值:如果CC1,返回到最后交易的周期,否则返回0
YDB赋值:如果DD1,返回DD1日前的最低价,否则返回最低价
DDTS1赋值:如果DD1,返回DD1日前的DDTS,否则返回DDTS
DDCS1赋值:DDTS1的最后一日取值设为常数
ZDB赋值:DD1+1日前的YDB
DDTS2赋值:DD1+1日前的DDTS1
DDCS2赋值:DDTS2的最后一日取值设为常数
当满足条件到最后交易的周期=DDCS2时,在最低价位置画直线起点,当满足条件是否最后一个周期时,在DDCS2-1日前的最低价位置画直线终点,1表示是否延长.,COLOR00FF00,POINTDOT,线宽为2
当满足条件到最后交易的周期=DDCS1时,在最低价位置画直线起点,当满足条件是否最后一个周期时,在DDCS1-1日前的最低价位置画直线终点,1表示是否延长.,COLOR00FF00,POINTDOT,线宽为2
LAA赋值:10日前的最高价=2*10+1日内最高价的最高值
LQY赋值:若LAA则将最近10+1周期置为1
LCC赋值:LQY的10日过滤 AND 最高价=10+1日内最高价的最高值
LDDD赋值:上次LCC距今天数
LGDTS赋值:如果LCC,返回到最后交易的周期,否则返回0
LDINGBU赋值:如果LDDD,返回LDDD日前的最高价,否则返回最高价
LDINGBUTS赋值:如果LDDD,返回LDDD日前的LGDTS,否则返回LGDTS
LDINGBU1赋值:LDDD+1日前的LDINGBU
LGDCS1赋值:LDINGBUTS的最后一日取值设为常数
LDINGBUTS1赋值:LDDD+1日前的LDINGBUTS
LGDCS2赋值:LDINGBUTS1的最后一日取值设为常数
LDINGBU2赋值:LDDD+1日前的LDINGBU1
LMM赋值:如果到最后交易的周期>LGDCS2,返回0,否则返回1
输出分析家公式网HTTP://WWW.70822.COM整理:当满足条件到最后交易的周期=LGDCS2时,在最高价位置画直线起点,当满足条件到最后交易的周期=LGDCS1时,在最高价位置画直线终点,1表示是否延长.,画洋红色
当满足条件到最后交易的周期=LGDCS2时,在最高价位置画直线起点,当满足条件是否最后一个周期时,在LGDCS2-1日前的最高价位置画直线终点,1表示是否延长.,COLOR00FF00,POINTDOT
当满足条件到最后交易的周期=LGDCS1时,在最高价位置画直线起点,当满足条件是否最后一个周期时,在LGDCS1-1日前的最高价位置画直线终点,1表示是否延长.,COLOR00FF00,POINTDOT
LAA1赋值:10日前的最低价=2*10+1日内最低价的最低值
LQY1赋值:若LAA1则将最近10+1周期置为1
LCC1赋值:LQY1的10日过滤 AND 最低价=10+1日内最低价的最低值
LDD1赋值:上次LCC1距今天数
LDDTS赋值:如果LCC1,返回到最后交易的周期,否则返回0
LYDB赋值:如果LDD1,返回LDD1日前的最低价,否则返回最低价
LDDTS1赋值:如果LDD1,返回LDD1日前的LDDTS,否则返回LDDTS
LDDCS1赋值:LDDTS1的最后一日取值设为常数
LZDB赋值:LDD1+1日前的LYDB
LDDTS2赋值:DD1+1日前的LDDTS1
LDDCS2赋值:LDDTS2的最后一日取值设为常数
输出支撑:当满足条件到最后交易的周期=LDDCS2时,在最低价位置画直线起点,当满足条件到最后交易的周期=LDDCS1时,在最低价位置画直线终点,1表示是否延长.,画洋红色
LLAA赋值:5日前的最高价=2*5+1日内最高价的最高值
LLQY赋值:若LLAA则将最近5+1周期置为1
LLCC赋值:LLQY的5日过滤 AND 最高价=5+1日内最高价的最高值
LLDDD赋值:上次LLCC距今天数
LLGDTS赋值:如果LLCC,返回到最后交易的周期,否则返回0
LLDINGBU赋值:如果LLDDD,返回LLDDD日前的最高价,否则返回最高价
LLDINGBUTS赋值:如果LLDDD,返回LLDDD日前的LLGDTS,否则返回LLGDTS
LLDINGBU1赋值:LLDDD+1日前的LLDINGBU
LLGDCS1赋值:LLDINGBUTS的最后一日取值设为常数
LLDINGBUTS1赋值:LLDDD+1日前的LLDINGBUTS
LLGDCS2赋值:LLDINGBUTS1的最后一日取值设为常数
LLDINGBU2赋值:LLDDD+1日前的LLDINGBU1
LLMM赋值:如果到最后交易的周期>LGDCS2,返回0,否则返回1
输出L压力:当满足条件到最后交易的周期=LLGDCS2时,在最高价位置画直线起点,当满足条件到最后交易的周期=LLGDCS1时,在最高价位置画直线终点,1表示是否延长.,画洋红色
当满足条件到最后交易的周期=LLGDCS2时,在最高价位置画直线起点,当满足条件是否最后一个周期时,在LLGDCS2-1日前的最高价位置画直线终点,1表示是否延长.,COLOR00FF00,POINTDOT
当满足条件到最后交易的周期=LLGDCS1时,在最高价位置画直线起点,当满足条件是否最后一个周期时,在LLGDCS1-1日前的最高价位置画直线终点,1表示是否延长.,COLOR00FF00,POINTDOT
LLAA1赋值:5日前的最低价=2*5+1日内最低价的最低值
LLQY1赋值:若LLAA1则将最近5+1周期置为1
LLCC1赋值:LLQY1的5日过滤 AND 最低价=5+1日内最低价的最低值
LLDD1赋值:上次LCC1距今天数
LLDDTS赋值:如果LLCC1,返回到最后交易的周期,否则返回0
LLYDB赋值:如果LLDD1,返回LLDD1日前的最低价,否则返回最低价
LLDDTS1赋值:如果LLDD1,返回LLDD1日前的LLDDTS,否则返回LDDTS
LLDDCS1赋值:LLDDTS1的最后一日取值设为常数
LLZDB赋值:LLDD1+1日前的LLYDB
LLDDTS2赋值:DD1+1日前的LLDDTS1
LLDDCS2赋值:LLDDTS2的最后一日取值设为常数
输出L支撑:当满足条件到最后交易的周期=LLDDCS2时,在最低价位置画直线起点,当满足条件到最后交易的周期=LLDDCS1时,在最低价位置画直线终点,1表示是否延长.,画洋红色
LZGSTAR赋值:(L压力+L支撑)/2
LZGEND赋值:(L压力+L支撑)/2的最后一日取值设为常数
LSTARDAY赋值:如果LLDDCS2<LLGDCS2,返回LLDDCS2,否则返回LLGDCS2
输出MA1:收盘价的18日简单移动平均,画白色,线宽为1
输出均线:收盘价的20日简单移动平均,画白色,线宽为1
RSV赋值:(收盘价-M日内最低价的最低值)/(M日内最高价的最高值-M日内最低价的最低值)*100,线宽为2
输出K1:RSV的3日[1日权重]移动平均,线宽为1
输出D5:K1的3日[1日权重]移动平均,线宽为1
输出J:3*K1-2*D5,COLORFF00FF,线宽为1
D1赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均的5日指数移动平均
D2赋值:1日前的D1
当满足条件D1>=1日前的D1时,在D1和D2位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR0055AA
当满足条件D1<1日前的D1时,在D1和D2位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR006600
当满足条件D1>=1日前的D1时,在D1和D2位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0099DD
当满足条件D1<1日前的D1时,在D1和D2位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00BB00
VARK1赋值:(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100
VARK2赋值:VARK1的相反数
VARK3赋值:VARK1的3日[1日权重]移动平均
输出波段王:VARK3的3日[1日权重]移动平均,画红色,线宽为2
输出波段鬼:波段王的2.5日[1日权重]移动平均,画蓝色,线宽为2
K赋值:波段王>1日前的波段王
如果K-1,返回波段王,否则返回无效数,画绿色,线宽为2
D赋值:波段鬼>1日前的波段鬼
如果D-1,返回波段鬼,否则返回无效数,画绿色,线宽为2
VAR51赋值:75日内最低价的最低值
VAR61赋值:75日内最高价的最高值
VAR71赋值:(VAR61-VAR51)/100
VAR81赋值:(收盘价-VAR51)/VAR71的20日[1日权重]移动平均
VAR91赋值:(开盘价-VAR51)/VAR71的20日[1日权重]移动平均
VARA1赋值:3*VAR81-2*VAR81的15日[1日权重]移动平均
VARB1赋值:3*VAR91-2*VAR91的15日[1日权重]移动平均
VARC1赋值:100-VARB1
输出看(我)实力: (100-VARA1),线宽为4,画绿色 
P赋值:看(我)实力>1日前的看(我)实力
如果P-1,返回看(我)实力,否则返回无效数,画红色,线宽为4
输出买点准备信号: 10
输出卖点准备信号:100
输出强弱分界: 50,CIRCLEDOT
A1赋值:上次1日前的"平滑异同平均的DIF"上穿"平滑异同平均的DEA"距今天数
B1赋值:A1+1日前的收盘价> 收盘价 AND A1+1日前的"平滑异同平均的DIF"<"平滑异同平均的DIF" AND "平滑异同平均的DIF"上穿"平滑异同平均的DEA"
当满足条件B1>0时,在D1位置书写文字,COLOR00FFFF
 

源码:

 

 

M:=3;
AA:=REF(H,20)=HHV(H,2*20+1);
QY:=BACKSET(AA,20+1);
CC:=FILTER(QY,20) AND H=HHV(H,20+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1),COLORMAGENTA;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR00FF00,POINTDOT,LINETHICK2;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLOR00FF00,POINTDOT,LINETHICK2;
AA1:=REF(L,20)=LLV(L,2*20+1);
QY1:=BACKSET(AA1,20+1);
CC1:=FILTER(QY1,20) AND L=LLV(L,20+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLOR00FF00,POINTDOT,LINETHICK2;
DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLOR00FF00,POINTDOT,LINETHICK2;
LAA:=REF(H,10)=HHV(H,2*10+1);
LQY:=BACKSET(LAA,10+1);
LCC:=FILTER(LQY,10) AND H=HHV(H,10+1);
LDDD:=BARSLAST(LCC);
LGDTS:=IF(LCC,CURRBARSCOUNT,0);
LDINGBU:=IF(LDDD,REF(H,LDDD),H);{顶部}
LDINGBUTS:=IF(LDDD,REF(LGDTS,LDDD),LGDTS);
LDINGBU1:=REF(LDINGBU,LDDD+1);
LGDCS1:=CONST(LDINGBUTS);
LDINGBUTS1:=REF(LDINGBUTS,LDDD+1);
LGDCS2:=CONST(LDINGBUTS1);
LDINGBU2:=REF(LDINGBU1,LDDD+1);
LMM:=IF(CURRBARSCOUNT>LGDCS2,0,1);
压力:DRAWLINE(CURRBARSCOUNT=LGDCS2,H,CURRBARSCOUNT=LGDCS1,H,1),COLORMAGENTA;
DRAWLINE(CURRBARSCOUNT=LGDCS2,H,ISLASTBAR,REF(H,LGDCS2-1),1),COLOR00FF00,POINTDOT;
DRAWLINE(CURRBARSCOUNT=LGDCS1,H,ISLASTBAR,REF(H,LGDCS1-1),1),COLOR00FF00,POINTDOT;
LAA1:=REF(L,10)=LLV(L,2*10+1);
LQY1:=BACKSET(LAA1,10+1);
LCC1:=FILTER(LQY1,10) AND L=LLV(L,10+1);
LDD1:=BARSLAST(LCC1);
LDDTS:=IF(LCC1,CURRBARSCOUNT,0);
LYDB:=IF(LDD1,REF(L,LDD1),L);
LDDTS1:=IF(LDD1,REF(LDDTS,LDD1),LDDTS);
LDDCS1:=CONST(LDDTS1);
LZDB:=REF(LYDB,LDD1+1);
LDDTS2:=REF(LDDTS1,DD1+1);
LDDCS2:=CONST(LDDTS2);
支撑:DRAWLINE(CURRBARSCOUNT=LDDCS2,L,CURRBARSCOUNT=LDDCS1,L,1),COLORMAGENTA;LLAA:=REF(H,5)=HHV(H,2*5+1);
LLQY:=BACKSET(LLAA,5+1);
LLCC:=FILTER(LLQY,5) AND H=HHV(H,5+1);
LLDDD:=BARSLAST(LLCC);
LLGDTS:=IF(LLCC,CURRBARSCOUNT,0);
LLDINGBU:=IF(LLDDD,REF(H,LLDDD),H);{顶部}
LLDINGBUTS:=IF(LLDDD,REF(LLGDTS,LLDDD),LLGDTS);
LLDINGBU1:=REF(LLDINGBU,LLDDD+1);
LLGDCS1:=CONST(LLDINGBUTS);
LLDINGBUTS1:=REF(LLDINGBUTS,LLDDD+1);
LLGDCS2:=CONST(LLDINGBUTS1);
LLDINGBU2:=REF(LLDINGBU1,LLDDD+1);
LLMM:=IF(CURRBARSCOUNT>LGDCS2,0,1);
L压力:DRAWLINE(CURRBARSCOUNT=LLGDCS2,H,CURRBARSCOUNT=LLGDCS1,H,1),COLORMAGENTA;
DRAWLINE(CURRBARSCOUNT=LLGDCS2,H,ISLASTBAR,REF(H,LLGDCS2-1),1),COLOR00FF00,POINTDOT;
DRAWLINE(CURRBARSCOUNT=LLGDCS1,H,ISLASTBAR,REF(H,LLGDCS1-1),1),COLOR00FF00,POINTDOT;
LLAA1:=REF(L,5)=LLV(L,2*5+1);
LLQY1:=BACKSET(LLAA1,5+1);
LLCC1:=FILTER(LLQY1,5) AND L=LLV(L,5+1);
LLDD1:=BARSLAST(LCC1);
LLDDTS:=IF(LLCC1,CURRBARSCOUNT,0);
LLYDB:=IF(LLDD1,REF(L,LLDD1),L);
LLDDTS1:=IF(LLDD1,REF(LLDDTS,LLDD1),LDDTS);
LLDDCS1:=CONST(LLDDTS1);
LLZDB:=REF(LLYDB,LLDD1+1);
LLDDTS2:=REF(LLDDTS1,DD1+1);
LLDDCS2:=CONST(LLDDTS2);
L支撑:DRAWLINE(CURRBARSCOUNT=LLDDCS2,L,CURRBARSCOUNT=LLDDCS1,L,1),COLORMAGENTA;
LZGSTAR:=(L压力+L支撑)/2;
LZGEND:=CONST((L压力+L支撑)/2);
LSTARDAY:=IF(LLDDCS2<LLGDCS2,LLDDCS2,LLGDCS2);
MA1:MA(CLOSE,18),COLORWHITE,LINETHICK1;
MA2:MA(CLOSE,20),COLORWHITE,LINETHICK1;RSV:=(CLOSE-LLV(LOW,M))/(HHV(HIGH,M)-LLV(LOW,M))*100,LINETHICK2;
K1:SMA(RSV,3,1),LINETHICK1;
D5:SMA(K1,3,1),LINETHICK1;
J:3*K1-2*D5,COLORFF00FF,LINETHICK1;D1:=EMA(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),5);
D2:=REF(D1,1);
STICKLINE(D1>=REF(D1,1),D1,D2,5,0),COLOR0055AA;
STICKLINE(D1<REF(D1,1),D1,D2,5,0),COLOR006600;
STICKLINE(D1>=REF(D1,1),D1,D2,1,0),COLOR0099DD;
STICKLINE(D1<REF(D1,1),D1,D2,1,0),COLOR00BB00;VARK1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VARK2:=REVERSE(VARK1);
VARK3:=SMA(VARK1,3,1);
波段王:SMA(VARK3,3,1),COLORRED,LINETHICK2;
波段鬼:SMA(波段王,2.5,1),COLORBLUE,LINETHICK2;K:=波段王>REF(波段王,1);
IF(K-1,波段王,DRAWNULL),COLORGREEN,LINETHICK2;
D:=波段鬼>REF(波段鬼,1);
IF(D-1,波段鬼,DRAWNULL),COLORGREEN,LINETHICK2;
VAR51:=LLV(LOW,75);
VAR61:=HHV(HIGH,75);
VAR71:=(VAR61-VAR51)/100;
VAR81:=SMA((CLOSE-VAR51)/VAR71,20,1);
VAR91:=SMA((OPEN-VAR51)/VAR71,20,1);
VARA1:=3*VAR81-2*SMA(VAR81,15,1);
VARB1:=3*VAR91-2*SMA(VAR91,15,1);
VARC1:=100-VARB1;
看(我)实力: (100-VARA1),LINETHICK4,COLORGREEN ;
P:=看(我)实力>REF(看(我)实力,1);
IF(P-1,看(我)实力,DRAWNULL),COLORRED,LINETHICK4;
买点准备信号: 10;
卖点准备信号:100;
强弱分界: 50,CIRCLEDOT;
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)> C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");
DRAWTEXT(B1> 0,D1,'MACD底背离'),COLOR00FFFF;



买好股公式网推荐理由:公式有未来函数,但是MACD底背离相当准确。

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,交易模型,选股公式,还原公式的朋友

可联系技术人员 QQ: 262069696  点击在线交流或微信:cxhjy888 进行 有偿收费 编写!(注:由于人数限制,QQ或微信请选择方便的一个联系我们就行,加好友时请简单备注下您的需求,否则无法通过。谢谢您!)

怎么收费,代编流程等详情请点击查阅!

(注:由于人数限制,QQ或微信请选择方便的一个联系我们就行,加好友时请简单备注下您的需求,否则无法通过。谢谢您!)

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容