请帮忙改一下-文华财经知识 -程序化交易(CXH99.COM)
您现在的位置:程序化交易>> 期货公式>> 文华财经>> 文华财经知识>>正文内容

请帮忙改一下 [文华财经]

  • 咨询内容:  

     


    老笔:=1;
     G:=MA(C,5);
     D:=MA(C,10);
     HH:=REF(H,5)=HHV(H,11);
     LL:=REF(L,5)=LLV(L,11);
     FG01:=BACKSET(HH,6)>BACKSET(HH,5) ;
     FD01:=BACKSET(LL,6)>BACKSET(LL,5) ;
     FG02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND G>D,FG01,
     IF(BARSLAST(FD01)>BARSLAST(FG01),FG01,0));
     FD02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND D>G,FD01,
     IF(BARSLAST(FG01)>BARSLAST(FD01),FD01,0));
     FG0:=FG02 AND H=HHV(H,BARSLAST(FD02));
     FD0:=FD02 AND L=LLV(L,BARSLAST(FG02));
     GP:IF(FG0,H,DRAWNULL),CIRCLEDOT,COLORCYAN,LINETHICK4;
     DP:IF(FD0,L,DRAWNULL),CIRCLEDOT,COLORCYAN,LINETHICK4;
     GQ:=L>REF(H,1) AND DAY!=REF(DAY,1);
     DQ:=H<REF(L,1) AND DAY!=REF(DAY,1);
     GQL:=REF(L,BARSLAST(GQ));
     DQH:=REF(H,BARSLAST(DQ));
     FGH:=REF(H,BARSLAST(FG0));
     FGL:=REF(L,BARSLAST(FG0));
     FGH1:=REF(H,BARSLAST(FG0)+1);
     FGL1:=REF(L,BARSLAST(FG0)+1);
     FGH2:=REF(H,BARSLAST(FG0)+2);
     FGL2:=REF(L,BARSLAST(FG0)+2);
     FDH:=REF(H,BARSLAST(FD0));
     FDL:=REF(L,BARSLAST(FD0));
     FDH1:=REF(H,BARSLAST(FD0)+1);
     FDL1:=REF(L,BARSLAST(FD0)+1);
     FDH2:=REF(H,BARSLAST(FD0)+2);
     FDL2:=REF(L,BARSLAST(FD0)+2);
     FGZH:=IF(FGL<=FGL1,FGH2,FGH1);
     FGZL:=IF(FGH1<FGL,FGL,IF(FGL<=FGL1,FGL2,FGL1));
     FDZH:=IF(FDL1>FDH,FDH,IF(FDH>=FDH1,FDH2,FDH1));
     FDZL:=IF(FDH>=FDH1,FDL2,FDL1);
     FG1:=FGH>FDZH AND FG0;
     FD1:=FDL<FGZL AND FD0;
     FG:=FG1 AND FGH>FDH AND FGL>FDL AND FGL1>FDL;
     FD:=FD1 AND FDL<FGL AND FDH<FGH AND FDH1<FGH;
     BH0:=(H<=REF(H,1) AND L>=REF(L,1)) OR (H>=REF(H,1) AND L<=REF(L,1));
     BHG:=COUNT(BH0,BARSLAST(FD0));
     BHD:=COUNT(BH0,BARSLAST(FG0));
     BGQ:=COUNT(GQ,BARSLAST(FD0));
     BDQ:=COUNT(DQ,BARSLAST(FG0));
     BK0:=IF(BHG>0,BHG+2+老笔,IF(BHD,BHD+2+老笔,3));
     BK:=IF(BGQ,BK0-BGQ,IF(BDQ,BK0-BDQ,BK0));
     G1X:=(FG AND BARSLAST(FD)>BK);
     D1X:=(FD AND BARSLAST(FG)>BK);
     G1W:=(FG0 AND REF(H,BARSLAST(FG0))>=REF(H,BARSLAST(G1X)) AND BARSLAST(D1X)>BARSLAST(G1X))
     OR (FG1 AND COUNT(GQ,BARSLAST(FD1))>0 AND REF(H,BARSLAST(FG1))>REF(H,BARSLAST(G1X)));
     D1W:=(FD0 AND REF(L,BARSLAST(FD0))<=REF(L,BARSLAST(D1X)) AND BARSLAST(G1X)>BARSLAST(D1X))
     OR (FD1 AND COUNT(DQ,BARSLAST(FG1))>0 AND REF(L,BARSLAST(FD1))<REF(H,BARSLAST(D1X)));
     G1H:=IF(BARSLAST(D1W)>BARSLAST(G1W),REF(H,BARSLAST(G1W)),REF(H,BARSLAST(D1W))),;
     D1L:=IF(BARSLAST(G1W)>BARSLAST(D1W),REF(L,BARSLAST(D1W)),REF(L,BARSLAST(G1W)));
     G2W:=G1W AND H=HHV(G1H,BARSLAST(D1W)+1) AND H>REF(H,1) AND BARSLAST(D1W)>BARSLAST(G1W);
     D2W:=D1W AND L=LLV(D1L,BARSLAST(G1W)+1) AND L<REF(L,1) AND BARSLAST(G1W)>BARSLAST(D1W);
     G3W:=G2W OR (FG0 AND REF(H,BARSLAST(FG0))>REF(H,BARSLAST(G2W)) AND BARSLAST(D2W)>BARSLAST(G2W));
     D3W:=D2W OR (FD0 AND REF(L,BARSLAST(FD0))<REF(L,BARSLAST(D2W)) AND BARSLAST(G2W)>BARSLAST(D2W));
     GPB:IF(G1X,H,DRAWNULL),CIRCLEDOT,COLORYELLOW,LINETHICK4;
     DPB:IF(D1X,L,DRAWNULL),CIRCLEDOT,COLORYELLOW,LINETHICK4;
     {画线}
     NNW:=G3W;
     UUW:=D3W;
     LW1:DRAWLINE(UUW,L,NNW, H,0),COLORRED,LINETHICK3;
     LW2:DRAWLINE(NNW,H,UUW, L,0),COLORGREEN,LINETHICK3;

     

     来源:程序化99

  • 文华技术人员:  参考:
    老笔:=1;  G:=MA(C,5);  D:=MA(C,10);  HH:=REF(H,5)=HHV(H,11);  LL:=REF(L,5)=LLV(L,11);  FG01:=BACKSET(HH,6)>BACKSET(HH,5) ;  FD01:=BACKSET(LL,6)>BACKSET(LL,5) ;  FG02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND G>D,FG01,  IF(BARSLAST(FD01)>BARSLAST(FG01),FG01,0));  FD02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND D>G,FD01,  IF(BARSLAST(FG01)>BARSLAST(FD01),FD01,0));  FG0:=FG02 AND H=HHV(H,BARSLAST(FD02));  FD0:=FD02 AND L=LLV(L,BARSLAST(FG02));  GP:IF(FG0,H,NULL),CIRCLEDOT,COLORCYAN,LINETHICK4;  DP:IF(FD0,L,NULL),CIRCLEDOT,COLORCYAN,LINETHICK4;  GQ:=L>REF(H,1) AND DAY=REF(DAY,1);  DQ:=H<REF(L,1) AND DAY=REF(DAY,1);  GQL:=REF(L,BARSLAST(GQ));  DQH:=REF(H,BARSLAST(DQ));  FGH:=REF(H,BARSLAST(FG0));  FGL:=REF(L,BARSLAST(FG0));  FGH1:=REF(H,BARSLAST(FG0)+1);  FGL1:=REF(L,BARSLAST(FG0)+1);  FGH2:=REF(H,BARSLAST(FG0)+2);  FGL2:=REF(L,BARSLAST(FG0)+2);  FDH:=REF(H,BARSLAST(FD0));  FDL:=REF(L,BARSLAST(FD0));  FDH1:=REF(H,BARSLAST(FD0)+1);  FDL1:=REF(L,BARSLAST(FD0)+1);  FDH2:=REF(H,BARSLAST(FD0)+2);  FDL2:=REF(L,BARSLAST(FD0)+2);  FGZH:=IF(FGL<=FGL1,FGH2,FGH1);  FGZL:=IF(FGH1<FGL,FGL,IF(FGL<=FGL1,FGL2,FGL1));  FDZH:=IF(FDL1>FDH,FDH,IF(FDH>=FDH1,FDH2,FDH1));  FDZL:=IF(FDH>=FDH1,FDL2,FDL1);  FG1:=FGH>FDZH AND FG0;  FD1:=FDL<FGZL AND FD0;  FG:=FG1 AND FGH>FDH AND FGL>FDL AND FGL1>FDL;  FD:=FD1 AND FDL<FGL AND FDH<FGH AND FDH1<FGH;  BH0:=(H<=REF(H,1) AND L>=REF(L,1)) OR (H>=REF(H,1) AND L<=REF(L,1));  BHG:=COUNT(BH0,BARSLAST(FD0));  BHD:=COUNT(BH0,BARSLAST(FG0));  BGQ:=COUNT(GQ,BARSLAST(FD0));  BDQ:=COUNT(DQ,BARSLAST(FG0));  BK0:=IF(BHG>0,BHG+2+老笔,IF(BHD,BHD+2+老笔,3));  BK1:=IF(BGQ,BK0-BGQ,IF(BDQ,BK0-BDQ,BK0));  G1X:=(FG AND BARSLAST(FD)>BK1);  D1X:=(FD AND BARSLAST(FG)>BK1);  G1W:=(FG0 AND REF(H,BARSLAST(FG0))>=REF(H,BARSLAST(G1X)) AND BARSLAST(D1X)>BARSLAST(G1X))  OR (FG1 AND COUNT(GQ,BARSLAST(FD1))>0 AND REF(H,BARSLAST(FG1))>REF(H,BARSLAST(G1X)));  D1W:=(FD0 AND REF(L,BARSLAST(FD0))<=REF(L,BARSLAST(D1X)) AND BARSLAST(G1X)>BARSLAST(D1X))  OR (FD1 AND COUNT(DQ,BARSLAST(FG1))>0 AND REF(L,BARSLAST(FD1))<REF(H,BARSLAST(D1X)));  G1H:=IF(BARSLAST(D1W)>BARSLAST(G1W),REF(H,BARSLAST(G1W)),REF(H,BARSLAST(D1W)));  D1L:=IF(BARSLAST(G1W)>BARSLAST(D1W),REF(L,BARSLAST(D1W)),REF(L,BARSLAST(G1W)));  G2W:=G1W AND H=HHV(G1H,BARSLAST(D1W)+1) AND H>REF(H,1) AND BARSLAST(D1W)>BARSLAST(G1W);  D2W:=D1W AND L=LLV(D1L,BARSLAST(G1W)+1) AND L<REF(L,1) AND BARSLAST(G1W)>BARSLAST(D1W);  G3W:=G2W OR (FG0 AND REF(H,BARSLAST(FG0))>REF(H,BARSLAST(G2W)) AND BARSLAST(D2W)>BARSLAST(G2W));  D3W:=D2W OR (FD0 AND REF(L,BARSLAST(FD0))<REF(L,BARSLAST(D2W)) AND BARSLAST(G2W)>BARSLAST(D2W));  GPB:IF(G1X,H,NULL),CIRCLEDOT,COLORYELLOW,LINETHICK4;  DPB:IF(D1X,L,NULL),CIRCLEDOT,COLORYELLOW,LINETHICK4;  {画线}  NNW:=G3W;  UUW:=D3W; DRAWLINE1(UUW,L,NNW, H,0),COLORRED,LINETHICK3; DRAWLINE1(NNW,H,UUW, L,0),COLORGREEN,LINETHICK3;

     

     来源: WWW.CXH99.COM

  • 文华客服:  老师不显示画线

     

  • 网友回复:  可以显示的。您把指标属性设置为k线附属指标就可以了
     您重新加载看下

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容